Recommended Posts

1-el problema es que no tiene conexión el sistema de facturacion de EGA con IMPRESORA hasar

2-cuando ejecuto utilidad de hasar FDIAG, reconoce la IMPRESORA hasar en puerto com1 y además tiro impresión sin problemas

3-cuando entro al stockbase no puedo conf. Puerto osea lo coloco en com1 y no encuentra la hasar TIRANDO ERROR

Conclusión parece ser que fuera de Windows funciona y bajo Windows no funciona(tmb probe cambiando baudios recomendados por uds)

Incluso probé en otra pc y me da el mismo error

  • Like 2
Enlace al mensaje

El software de hasar deja mucho que desear, y hace lo minimo e indispensable: verificar que la impresora fiscal no tenga problemas tecnicos. nada mas.

El problema es que al funcionar bajo DOS, nada te garantiza que tengas comunicacion bajo Windows,

El puerto serie de tu computadora es pci o es onboard? Te pregunto esto porque yo lo resolvi instalando un puerto pci. Imagen enviada

  • Like 1
Enlace al mensaje

Excelente aporte Ricardo!

Es muy importante tener esto:

  • Las impresoras fiscales suelen NO FUNCIONAR con puertos on-board Imagen enviada
  • Es necesario instalar una placa PCI para el puerto serie
  • A lo largo del tiempo, hemos detectado que las impresoras fiscales Hasar, funcionan mejor si se las conecta a COM1

Te recomiendo mucho leer esto: http://www.egafutura.com/soporte-gestion/impresoras-fiscales

57d718904d68fa794d1e8bdb_solucion-hardwa

  • Like 2
Enlace al mensaje
En 8/9/2011 at 14:27 , 'gus dijo:

EL PUERTO ES ONBORAD Y FUNCIONÒ POR AÑOS SIN MAYORES PROBLEMAS, DE REPENTE ENCONTRAMOS ESTE ERROR Y SE COMPLICO TODO. TRATARE DE BUSCAR UNA PLACA PCI Y VEREMOS.GRACIAS

Genial Gustavo!

El camino correcto es instalar una placa PCI junto con los drivers originales del fabricante. Esperamos tus novedades! Imagen enviada

58864495842481330a874e42_EGAFutura-impre

Enlace al mensaje
En 8/9/2011 a las 18:33, 'gus dijo:

bueno despues de comprar la placa pci... instale y conf. en com1 y........lluvia de plopsssss........ el mismo error ante mi ojos!!!!!y ahora......

Ahora es donde comienza la parte divertida: UN PROCESO DE PRUEBA Y ERROR HASTA EMBOCARLA.

Aqui encontre en el foro un lugar exactamente igual al tuyo: http://ayuda.egafutura.com/topic/176-solucionado-configuracion-de-impresora-fiscal-y-software-de-facturacion-version-2011620/

...

Me olvidaba, aqui hay mas informacion util para que veas: http://ayuda.egafutura.com/forum/25-impresoras-fiscales/ Imagen enviada

  • Like 1
Enlace al mensaje

Gustavo esto te esta ocurriendo porque el puerto RS232 de tu computadora no esta trabajando de la manera adecuada, por lo tanto no hay comunicación entre tu impresora fiscal y la PC.

excl.gif La instalacion de una placa PCI te garantiza que estas en el camino correcto y que de esa forma vas a encontrar la solucion. Pero hay que tener en cuenta que es común que no funcione en el primer intento. :me_equivoque:

 

588647fb92b6f2503f42ff08_EGAFutura-error


En el proceso de emisión de un comprobante fiscal, intervienen tres componentes:

  • Impresora fiscal
  • Computadora
  • Software de facturacion

Ante un problema o falla en la comunicación entre el software y la impresora fiscal, en mas de un 90% de los casos el inconveniente reside en la computadora. ¿Por qué?

  • Impresora fiscal: Vienen testeadas de fabrica. Solo fallan ante un desperfecto técnico. Son muy estables.
  • Software de punto de venta: Se instala, y lo único que debe hacerse es configurar dos cosas: puerto serie, y modelo del impresora. La re-instalación no influye.

 

La computadora tiene como principal falencia el puerto RS232, en el cual se conecta la impresora fiscal. Los puntos a tener en cuenta son:

  • Deshabilitar puertos "onboard"
  • Instalar una placa RS232 PCI o un adaptador USB->RS232
  • Utilizar los drivers del fabricante de la placa, NO los predeterminados por la tecnología "plug and play" de Windows.
  • Variar la velocidad del puerto: 7200, 9600 y 14.400 baudios.

57dc0dc259d8cc6b4832decd_placa-pci-comun

La solución consiste en un proceso de prueba y error.


No todas las placas PCI son compatibles con una "placa madre" en particular, por lo que es necesario probar placas de diferentes fabricantes. También es recomendable verificar el estado de los pines de conexión, y reemplazar el cable para descartar daños internos.

El proceso, puede ser rápido, o arduo. El arribo a la solución genuina es el resultado de la cantidad de combinaciones adecuadas hasta que el impresor pueda emitir todo tipo de comprobantes, de manera estable y continuada.

Mas info aqui: http://www.egafutura.com/soporte-gestion/impresoras-fiscales

 

 

 

  • Like 1
Enlace al mensaje

bueno despues de luchar duro y probar mas de una PCI, baudios y otras yerbas les cuento que solucione el problema registrando las ocx nuevamente y salio andando perfecto, asi que agreguen este tips a su detallado banco de errores y me deben una!!!! :)

Y como suponia no era problema de puerto! por que quedo andando el onboard! Como venia funcionando antes.

saludos

  • Like 3
Enlace al mensaje
En 9/9/2011 a las 10:44, 'gus dijo:

bueno despues de luchar duro y probar mas de una pci, baudios y otras yerbas les cuento que solucione el problema registrando las ocx nuevamente y salio andando perfecto ,asi que agreguen este tips a su detallado banco de errores y me deben una!!!!

GUAT? Loco como hiciste eso? No entiendo, por mi experiencia (que son varios años) los puertos onboard al ser una emulacion de un puerto serie verdadero, terminan fallando.

Que es lo que verdaderamente hiciste? Imagen enviada

  • Like 2
Enlace al mensaje

No se puede! ya que tu abono no contempla dar a conocer la solucion!jajajaja como son las cosas.......

solamente registre todas las ocx del sistema de EGA Futura y listo , supongo que no tendre que explicarte como registrar una ocx.........

En 9/9/2011 at 11:58 , 'Ricardo5874 dijo:

GUAT? Loco como hiciste eso? No entiendo, por mi experiencia (que son varios años) los puertos onboard al ser una emulacion de un puerto serie verdadero, terminan fallando. Que es lo que verdaderamente hiciste? Imagen enviada

Enlace al mensaje

Si bien esto parece magia, la recomendación oficial sigue siendo no utilizar puertos onboard.

Lo extraño de todo esto, es que los OCXs se registran en el proceso de instalación del software.

De todas maneras, dejamos constancia de lo sucedido y nos alegramos de que el problema este solucionado! Imagen enviada

  • Like 3
Enlace al mensaje
En 9/9/2011 at 10:44 , 'gus dijo:

bueno despues de luchar duro y probar mas de una pci, baudios y otras yerbas les cuento que solucione el problema registrando las ocx nuevamente y salio andando perfecto ,asi que agreguen este tips a su detallado banco de errores y me deben una!!!!

Gracias Gus!! este problema de comunicación ya me tenía muy mal, y la cuestión era nomás un .OCX.

No siempre es cuestión de hacer toda una instalación nueva de la PC para vovler a tener el sistema andando.

Además, probé con la instalación de un placa PCI con puerto serial RS-232 sin éxito, es más, cuando logré solucionar el problema (gracias a tu experiancia) quité la placa PCI y volví a utilizar el puerto on-board sin ningún problema.

Siguiendo tu experiencia, intenté primero con "Fiscal051122.Ocx" (en C:StockBase POS 2012.663Win).

Como no tuve ningún resultado positivo des-registré este otro archivo "IFEpson.ocx" con el comando "regsvr32 /u C:StockBase POS 2012.663WinIFEpson.ocx"

Para luego volver a registrarlo con el comando "regsvr32C:StockBase POS 2012.663WinIFEpson.ocx", asunto SOLUCIONADO!! :)

No le tenía fé a este segundo archivo por que en el nombre dice "Epson" y mi impresora es una OKI Microline 320 Turbo (compatible con Hasar), pero esa fué la solución.

Aparentemente el problema empezó con la activación de una nueva versión del sistema de gestion de EGA Futura, pero por ahí fue casualidad.

Espero que esta info sea útil a otros!

  • Like 3
Enlace al mensaje
En 22/8/2012 at 12:08 , 'mark69 dijo:

Siguiendo tu experiencia, intenté primero con "Fiscal051122.Ocx" (en C:StockBase POS 2012.663Win), como no tuve ningún resultado positivo des-registré este otro archivo "IFEpson.ocx" con el comando "regsvr32 /u C:StockBase POS 2012.663WinIFEpson.ocx" para luego volver a registrarlo con el comando "regsvr32C:StockBase POS 2012.663WinIFEpson.ocx", a sunto SOLUCIONADO!!

Gracias gus y mark por confirmar que esto funciona, en la empresa de mi primo lo resolvieron de la misma manera. :muy_bueno:

  • Like 3
Enlace al mensaje

Muchas gracias por compartir esta experiencia con todos nosotros. Definitivamente la registracion de los componentes fiscales tanto de Hasar como de Epson puede fallar, y el proceso debe hacerse manualmente.

Pasando en limpio las instrucciones son:

  • Des-registrar los archivos "Fiscal051122.Ocx" y "IFEpson.ocx" con el comando "regsvr32 /u C:StockBase POS 2012.663WinIFEpson.ocx"
  • Luego volver a registrarlos con el comando "regsvr32 C:StockBase POS 2012.663WinIFEpson.ocx"

 

Notas importantes:

  • Estos dos comandos deben ejecutarse una vez para el archivo "Fiscal051122.Ocx" y otra vez para "IFEpson.ocx"
  • Reemplazar "C:StockBase POS 2012.663" por el nombre de la carpeta en donde se encuentra instalado el software de gestión.
Enlace al mensaje
En 25/7/2016 a las 16:11, LiniersDentalSa dijo:

Hola! Tuve problemas de conexión con la Fiscal Hasar cuando actualice a Windows 10. La PC es una AIO con la conexión USB to PORT. Probé un poco de todo investigando los foros Ega pero no tuve suerte. Volví a Windows 7 y anda perfecto! Hay alguna solución? 

El problema lo tenes en los driver del puerto serie de Windows 10.

La unica solucion es reemplazarlos como se especifica aqui: http://www.egafutura.com/soporte/gestion/impresoras-fiscales

 

5793e7211e7fa7340dc985f4_administrador-d

57dc0dc259d8cc6b4832decd_placa-pci-comun

Enlace al mensaje

Hola, como andan? de buenas a primeras el soft no me detecta la fiscal. Ya le hice una prueba de funcionamiento a la fiscal con su service oficial y esta en perfectas condiciones. 

Intalé la última versión en un PC NUEVA, hice la conversión de archivos y me sigue tirando el mismo error. La conexión que tengo es a través de Convert USB-serial el cual esta configurado en el COM1 e instalado correctamente. Hice las pruebas de errores como dice en el foro y nada....:desconcertado:

Cuando quiero agregar la Fiscal a los puntos de venta me aparecen estos errores, adjunto imágenes.

 

error 1.jpg

error 2.jpg

Enlace al mensaje
hace 1 hora, LiniersDentalSa dijo:

Intalé la última versión en un PC NUEVA, hice la conversión de archivos y me sigue tirando el mismo error. La conexión que tengo es a través de Convert USB-serial el cual esta configurado en el COM1 e instalado correctamente. Hice las pruebas de errores como dice en el foro y nada....:desconcertado:

Lo mas recomendable es que en esa PC:

  1. No uses un conversor USB,
  2. No user un puerto RS-232 OnBoard, y
  3. Hagas la instalacion de una placa PCI con un puerto RS-232 nuevo.

 

Un tecnico tuyo, debe tomarse el trabajo de hacer todo el proceso que se describe aqui.

588647fb92b6f2503f42ff08_EGAFutura-error

 

Muy importante:

  1. No hay una solución mágica, algo que yo te pueda decir "toca acá" o "toca allá" y listo. Cada PC es un mundo aparte y es por eso que es necesario que hagas lo que se describe en los audios de arriba.
  2. En caso de que no tengan un tecnico, pueden completar este formulario para que los pongamos en contacto con un distribuidor oficial.

58b4c516d56f799730f97091_EGAFutura-ingre

Enlace al mensaje
Invitado
Este tema está cerrado a más respuestas.