Recommended Posts

Hola buen día, quería pedir ayuda con un problema de instalación de la licencia gratis en tres pc's.

En la PC Server tengo el sistema instalado, funcionando correctamente. Para instalarlo en la PC Terminal 1 lo hice sin mayores inconvenientes (tuve algún par de errores que solucioné siguiendo los threads de otros usuarios con los mismos problemas y un poco de prueba y error)
*NOTA: Para que funcione en la PC Terminal 1 tuve que dejar la carpeta del software en el disco, sino no lograba que funcione*

 

En la PC Terminal 2 realicé la instalación siguiendo las idicaciones dadas en el soporte. Como no funcionó decidí reinstalarlo como en la PC Terminal 1 para ver si así (aunque no era lo recomendado) funcionaba. Tampoco logré que iniciara el sistema. Realicé en primer lugar la carga de registro.bat en la PC Server y, sin estar muy segura de por qué, también lo cargué en la PC Terminal 2 pero siguió todo exactamente igual.

Trabajo con Windows XP (PC Terminal 1 -dónde funciona- crackeado y en la PC Terminal 2 -dónde no funciona- es originial :desconcertado: ) y la versión actual 2014.762

 

Adjunto imágenes de los errores que me aparecen en PC Terminal 2 (que fueron los mismos que aparecieron en un principio en la PC Terminal 1 y logré solucionar)

 

Este fue el primer error que me salió (cuando me había olvidado de borrar la carpeta)

29555b4cc3f609dc5dc619c045b008db.png

 

Este fue el segundo (solo borré la carpeta del software de la PC Terminal 2)

d20b502da3f19a0e3c5c9895fc7935b1.png

 

Y luego apreté "Reintentar" y aparecía esto:
f897f266b7cd6f6b6c4ef51553426cdf.png

 

Si volvía a clickear en "Reintentar" pasaban dos cosas, al parecer aleatoriamente, o volvía al primer error que mostré o directamente se cerraba solo.

 

Quisiera saber qué puedo estar haciendo mal porque me gustaría poder poner el programa funcionar lo antes posible y si bien entiendo que migrar de un sistema a otro siempre acarrea problemas, este es uno que no puedo resolver mientras trabajo, así que por favor, ayuuuuda, ya nos se qué hacer :jackie:

 

Gracias de antemano,

Virginia.

 

------------------------------------------------------------------------------------------------------------------------------

EDIT

 

Logre "arreglar" el tema de la instalación en la PC Terminal 2, igual que en la la PC Terminal 1: A prueba y error. Pero me di cuenta que si bien en ambas terminales veía los clientes que tenía cargados en el server, la numeración de las facturas no estaba igual en todas las PC's, la verdad no se si esto último es un indicador de que mi mi red no está funcionando como debe o que es solo un detalle que hacer falta configurar. Lo que si, ya que estaba con esa duda reinicié todas las PC's y cuando las volví a iniciar me salía la advertencia de Termianl Abierta en la PC Terminal 2 (pero aún así podía iniciar el programa), lo solucioné con lo explicado en este post pero luego de arreglar ese problema me surgió uno mayor: Ahora el programa en la PC Terminal 2 queda en el inicio, cargando y cargando pero nunca logra abrirse:

443d83e4294a49428bdccfed444bd6c2.png

 

Alguien podría darme alguna posible solución para esto? U orientarme aunque sea?

Muchas gracias!

 

Enlace al mensaje

Gracias Virginia por la explicación detallada junto a todas las imágenes. :)

De todo lo que nos has comentado, esto me llamo poderosamente la atención:
 

Pero me di cuenta que si bien en ambas terminales veía los clientes que tenía cargados en el server, la numeración de las facturas no estaba igual en todas las PC's, la verdad no se si esto último es un indicador de que mi mi red no está funcionando como debe o que es solo un detalle que hacer falta configurar.



Es la primera vez que escucho esto. La totalidad de las bases de datos se almacenan en el servidor, por lo que no tiene sentido que existan numeraciones diferentes.

Podrías confirmar si tu red cumple con los requerimientos de cableado y hardware?:
http://www.EGAFutura.com/soporte/gestion/instalacion-red

Enlace al mensaje

Gracias por la respuesta Matías!

Antes de instalarlo me fijé que cumpla los requerimientos de hardware pero por las dudas ahora me fijé que todos los drivers estén correctamente instalados y sí, todo está cómo debería estar.
Lo que sí, ahora los números de facturación sí son los que deberían, pero yo no toqué nada, se corrigó solo :desconcertado:
EL problema que persiste es el de la advertencia de Terminal Abierta, solo que ahora me aparece de vez en cuando en todas las 3 PCs y algunas veces la PC Terminal 2 se queda intentando iniciar, sin mucho éxito. En ese caso la reinicio y vuelvo a ejecutar el acceso directo hasta que logro que funcione, no muy práctico pero es lo que puedo hacer hasta que se arregle :contento:

 

--------------------------------------------------------------------------------

EDIT

 

Bueno, hoy directamente no logré iniciar la PC Terminal 2 :asombro:

Enlace al mensaje

EL problema que persiste es el de la advertencia de Terminal Abierta, solo que ahora me aparece de vez en cuando en todas las 3 PCs y algunas veces la PC Terminal 2 se queda intentando iniciar, sin mucho éxito. En ese caso la reinicio y vuelvo a ejecutar el acceso directo hasta que logro que funcione, no muy práctico pero es lo que puedo hacer hasta que se arregle :contento:

 

Cuando el sistema abre el modulo de facturación o de configuración, hace un bloqueo de la terminal para evitar conflictos.

 

Eso significa que:

Enlace al mensaje

Entiendo, el tema es que me dice eso aún cuando el programa no se está ejecutando en las otras máquinas (comprobé que el BO.EXE no se estuviera ejecutando en segundo plano ni nada, para estar segura).

 

Muchas gracias por la explicación Fernando, aunque ahora no sea la solución me preguntaba qué significaba eso!

Enlace al mensaje

Respecto a la numeración de facturas (y demás comprobante) un comentario.

Si te fijas en las facturas seguramente veras que comienzan con un punto de venta distinto.

Ej: una factura de numeración 0001-00023 y otra factura con 0002-00002, la primera parte, antes del guion es el punto de venta, ya sea 0001 y 0003 (u el que corresponda)

 

Normalmente se configura un punto de venta en cada terminal, por ello tendrá numeración distinta en la numeración de comprobante.

 

Por favor verifica el tema del punto de venta y coméntanos como esta configurado.

Enlace al mensaje

Gracias Susana, ahora me pongo a ver eso,  si bien ya no tengo el problema, no está demás saber si funciona porque está bien configurado o solo de casualidad.

Al respecto de mi otro problema (el de la advertencia de "Terminal Abierta") ¿hay algo que me puedas recomentar? :)

Enlace al mensaje

Respecto a eso, puede ser a causa de varias cosas,

  • Causa: Archivo Terminales.DBT haciendo lio ...solución reemplazarlo por el una instalación limpia podes tomarlo desde la instalación base que se hace en la terminal)  y (deberás luego reconfigurar algunas cositas en configuración de la aplicación y por las dudas corroborar nuevamente el punto de venta)
  • Causa: Windows haciendo pavadas .. solución: cambiale el nombre de equipo a la pc.
  • Causa: Algo que no quedo bien instalado desde el principio ... Solución.. hacer todo desde cero.

hace las pruebas y comentanos como resultaron.

Cualquier cosa avisa.

 

Saludos!

Enlace al mensaje

Cambié el nombre de las PCs y ahora el StockBase abre en todas, lo que sí, sigue diciendo que tengo el problema de terminal abierta. La red está correctamente instalada, antes de reinstalar todo les comento lo de los puntos de venta.

Tengo un solo punto de venta el 0001, borré el 0003 que venía por defecto y asigné el 0001 a la PC Server, y ahora no puedo entrar a la configuración de Puntos de Venta desde ninguna PC ya que en todas me dice que tengo una "Terminal Abierta" ¿me mandé una macana al borrar el puesto de venta 0003?

Sigo con un problema pero ahora abre en todas las PCs, vamos progresando! Gracias a todos :)

Enlace al mensaje

Gracias Susana, hice lo que me recomendaste pero no me funcionó, así que para probar reinstalé todo en una de las terminales (PC Terminal 2). Ahora en la PC Server no me da error peeero el programa en la pc en la que reinstalé el StockBase POS me pasa algo similar a lo que me ocurría antes, con la diferencia de que ahora no puedo dejar la carpeta de intalación porque queda iniciando sin terminar de iniciar nunca y cuando las borro, ahí si, da los mismos errores que antes (los que adjunté cuando hice la pregunta). Ya registré los dll y los ocx pero no funciona :desconcertado:
No se qué hacer :(
 

Enlace al mensaje

En la terminal estas instalando como "terminal" ??

Recomendación...

  • Desinstala
  • Limpia registro
  • Reinstala pero como "pc principal", aunque sea terminal.
  • Inicia el prog dos o 3 veces hasta que deje de preguntar cosas.
  • No borres ninguna carpeta ni nada.
  • Mapea la unidad de red (donde esta compartida la instalación principal) http://www.egafutura.com/soporte/gestion/instalacion-red
  • Envía el BO al escritorio y ejecuta.

Así debería funcionar OK

 

Coméntanos como resulto.

Enlace al mensaje

En principio anduve averiguando a ver si alguien (aparte de ustedes a distancia claro :P) había tocado algo y no, nadie hizo nada. Empezaré a creer en duendes jajaja
Igual ahora que pude poner todo en marcha, cargar la lista de proveedores y productos me surgió otro temita con la factura, por si alguien quiere seguir dandome una mano, paso el link
http://ayuda.egafutura.com/topic/3738-descripci%C3%B3n-de-producto-duplicada/

Gracias a todos nuevamente :D

Enlace al mensaje

No hice NADA durante dos o tres días y cuando volvía mágicamente andaba todo bien... no entiendo nada... pero funciona! :muy_contento:

Gracias a todos!

 

Ese es el problema que tienes las redes locales, la tecnología de Microsoft que las soporta es inestable, y estas cosas son comunes. Cuando nuestro software en la nube este listo, dejaremos de darle soporte para entornos de red a StockBase POS con el objetivo de evitar exponer a nuestros usuarios a este tipo de complejidades.  :contento:

Enlace al mensaje

Enserio? Estoy armando todo para comprar las licencias, pero si no van a tener más soporte creo que todo el tiempo que estoy invirtiendo sería... al divino botón digamos

 

Tecnológicamente no vamos a discontinuar nada, eso significa que todos los que quieran usar StockBase POS en red van a poder continuar haciéndolo eternamente.

 

Lo que dejaremos de hacer es dar soporte técnico para las nuevas instalaciones, eso significa que si en el futuro una empresa quiere instalar nuestro sistema de facturación para Windows en red le diremos que:

  • Como no damos soporte, la instalacion en red la debe hacer por su propia cuenta, y que
  • Le recomendamos usar nuestro software en la nube, que es multi-usuario, multi-plataforma por naturaleza. 

 

Virginia en el caso puntual de ustedes, pueden quedarse tranquilos.  :contento:

Enlace al mensaje
  • 4 weeks later...

Archivado

Este tema está ahora archivado y está cerrado a más respuestas.

Invitado
Este tema está cerrado a más respuestas.